See https://support.esign-app.com for eSign Documentation and Support

KB101 - Troubleshooting Jira Security Permissions

Error

  • The Jira API returned a security error when eSign attempted to edit issue [Issue Number]. Review project security settings and contact support if the problem persists. (403)

  • eSign sends the project administrator an email: eSign encountered a problem generating and attaching the PDF Signature Archive to this issue. Review and contact your administrator or support for assistance. PDF Report failed to attach (403)

  • eSign reports an error like Issue not found (404) while a user attempts to Sign or interact with an existing issue.

Cause

eSign for Jira (App) user does not have access to view or edit the issue. As eSign stores the signature data via extended properties on the issues, this problem prevents signature data or the attachments from being stored.

This error can be encountered interactively when a user is working with eSign, or when eSign is triggered via a workflow post-function.

Things to Check

  1. Ensure the default Jira project role atlassian-addons-project-access has the following project permissions granted:

    • Browse Project

    • Edit Issues

    • Add Comments

    • Create Attachments

  2. Review the Jira workflow status properties and confirm that the property “jira.issue.editable=false” is NOT applied to any statuses. This flag will make the issue read-only for all users, including eSign. See Jira Workflow Configuration for alternatives to locking down issues for end-users only.

  3. By default, end users with Edit access to issues in the project will be allowed to Sign and Invite from eSign. If eSign Advanced (Fine-Grained) Security option has been enabled, Jira users will need additional eSign specific permissions granted to them directly or via roles/groups in the project permissions. See Project Settings for the description of permissions.